Issues after upgrade to version 2.81

We have some issues after upgraded to 2.81
Follow lines it's just an example of errors:

ERROR Wed Sep  2 12:01:13 2020 Error: show failed: Statistics collection for sample "9365_1599058502", was not completed successfully. Reason: "Request for 6212 instances of object client exceeds the limit of 5000. Use one or more of the following parameters to limit the number of instances: "-instance", "-node", "-vserver", "-filter"." Please delete this sample.

Wed Sep  2 12:01:14 2020: Cannot save data, System ID for Nas does not exists! /home/lpar2rrd/stor2rrd/bin/ :


Wed Sep  2 11:51:03 2020: Nas: LUN cfg file has not been found : /home/lpar2rrd/stor2rrd/data/Nas/LUN/luns.cfg /home/lpar2rrd/stor2rrd/bin/


Wed Sep  2 11:10:53 2020: XtremIO : load_host failed: ERROR: /home/lpar2rrd/stor2rrd/data/XtremIO/VOLUME/480350b7a2a7485eb02ecf3efa53d830.rrd: illegal attempt to update using time 1599051900 when last update time is 1599051900 (minimum one second step) at /home/lpar2rrd/stor2rrd/bin/ line 6508.

Use of uninitialized value $RRDp::error_mode in string eq at /usr/lib64/perl5/vendor_perl/ line 168.

The issue occur on Netapp – 8200 FAS and Dell Emc XtremIO.
The connection between xorux server ans storages systems is ok.

We have worked with the tool since 2018, and never get issues.


Could you help us, please?


  • Hi,

    NetApp hot fix:

            -rwxrwxr-x 1 stor2rrd stor2rrd 109605 Jul 13 12:15 bin/

            Gunzip it and copy to /home/stor2rrd/stor2rrd/bin/ (755, stor2rrd owner)

            If your web browser gunzips it automatically then just rename it: mv

            Assure that file size is the same as on above example

    You can ignore that XtremIO warning/error, it should work

  • Thank you for your answer.
    I will run this hot fix, and write about the result soon.
  • File size is not the same 

    -rwxrwxr-x 1 stor2rrd stor2rrd 99559 Sep  4 08:40 ../bin/

    And still not collecting 

    So now the errors occur in more one storage Netapp A700

    ERROR Fri Sep  4 09:00:06 2020 Error: show failed: Processing sample: "9365_1599220502". Please wait.
    Fri Sep  4 09:00:07 2020: Cannot save data, System ID for NetAppA700 does not exists! /home/lpar2rrd/stor2rrd/bin/ :

    ERROR Fri Sep  4 09:05:05 2020 Error: show failed: Processing sample: "9365_1599220802". Please wait.
    Fri Sep  4 09:05:05 2020: Cannot save data, System ID for Nas does not exists! /home/lpar2rrd/stor2rrd/bin/ :

  • Hello I am having the same issue with a NetApp fas9000 any idea what the solution is?

  • Hi,

    do you see data in graphs? Are there some gaps?
  • I Don't see any data in graphs on NetApp fas8200.
    Still got this issue, even tried upload this new file (on comments above), but isn't work.

  • Hi,

    send us logs and a screesnhot

    Note a short problem description in the text field of the upload form.

    cd /home/stor2rrd/stor2rrd # or where is your STOR2RRD working dir

    tar cvhf logs.tar logs tmp/*txt

    gzip -9 logs.tar

    Send us logs.tar.gz via

  • Hi,

    Thank you. Logs attached on
  • Hi,

    as per me NetAppA700 is working fine, send us a screenshot from the UI if does not.

    email: support at stor2rrd dot com

  • I'll try to upgrade to new version, as soon as possible, informe to you if works.
Sign In or Register to comment.