Stor2rrd with snmp v3 for Hitachi storage


I'm trying to setup stor2rrd to work with snmp v3, but I'm unable to get the health part working. In etc/storage-list.cfg I have the following configuration:


logs/error.log-vspg200 tells me:

Wed Oct 23 10:35:46 2019: Got Authentication failure (incorrect password, community or key) querying vspg200 for sysDescr.  /opt/stor2rrd/bin/ :

I get the same error if I'm using the unencrypted SHA and AES passphrases. If I run bin/ and take the snmpwalk line and insert the passwords, I see no problems:

[stor2rrd@test04 stor2rrd]$ snmpwalk -v 3 -u stor2rrd -l authPriv -A SHApassphrase -X AESpassphrase -a SHA -x AES vspg200
SNMPv2-SMI::enterprises. = STRING: "HM800"
SNMPv2-SMI::enterprises. = No more variables left in this MIB View (It is past the end of the MIB tree)

Is it a bug or am I doing something wrong?




  • Hello,

    Please send us output from command

    cd /home/stor2rrd/stor2rrd # or where is your STOR2RRD working dir

    ./bin/ vspg200

    Note: send us the output of the command above to email support(at)

    thank you
Sign In or Register to comment.