ERROR: Login to API failed

We are in the process of upgrading our Pure arrays from 4.10.10 to 5.3.0
For the arrays we have upgraded, I've noticed that no data is being collected and stor2rrd array log is saying 

ERROR: API version or Cookie is not defined! :
ERROR: Login to API failed :

The non-upgraded arrays show for  ./bin/ purestorage-alias01
Login to API succesfull: API version: 1.12
Purity version: 4.10.10

looking at https://arrayname/api/api_version
4.10.10 shows
{"version": ["1.0", "1.1", "1.2", "1.3", "1.4", "1.5", "1.6", "1.7", "1.8", "1.9", "1.10", "1.11", "1.12"]}
and 5.3.0 shows {"version": ["1.0", "1.1", "1.2", "1.3", "1.4", "1.5", "1.6", "1.7", "1.8", "1.9", "1.10", "1.11", "1.12", "1.13", "1.14", "1.15", "1.16", "1.17", "2.0"]}

From a previous discussion here, I downloaded this

and ran
./bin/ purestorage-alias01 > pure_debug.txt 2>&1

I have uploaded the log



  • Hello,

    unfortunately, the output did not reveal where is the error. Try this debug script:
    Gunzip it and copy to /home/stor2rrd/stor2rrd/bin (755, stor2rrd owner)
    -rwxr-xr-x 1 stor2rrd stor2rrd 5968  2. říj 13.28
    If your web browser gunzips it automatically then just rename it: mv

    please retest.

    ./bin/ purestorage-alias01 > pure_debug.txt 2>&1

    send us pure_debug.txt via

    note: It is possible that there are different keywords in the new api version. Do you have documentation? It should be installed on the box and accessible via GUI.

    Is there any REST API usage example? Can you provide us with documentation?

    Thank you
  • Hi Lukas,

    For the file you provided, the contents appear to be the one I already tried. The file size doesn't match what you list.

    I have tried to upload a number of files for the Rest API documentation (pdf & zip) to but I get the error below. Did the files upload?
    Do I need to do them one at a time?
    No such file or directory at /var/www/html/upload/cgi-bin/upload.cgi line 105.
  • Hello,

    I apologize for the inconvenience. now the upload should be working. Regarding file download. Try clearing your web browser cache or using a different browser.

    thank you
  • Hi Lukas,

    Yes, a different browser worked.
    I have uploaded the script output and Rest API documentation.
    Let me know if you need any more info or testing.

  • Patches provided by Lukas now allow a connection using Rest API version 1.17
Sign In or Register to comment.