I have systems in AWS Cloud, will this still work??

I tried to do the installation but nothing happened.  I used a local admin account on the host, which is an EC2 instance, I am able to connect to the lpar2rrd server (which has a ton of systems in it - this is the first Hyper-V or Windows though) and there are no errors when I run the setup.vbs although I don't see anything in the defined install directory and nothing is sent to the lpar2rrd server it would seem.

Are there use cases to just install the Windows Server Agent ignoring the Hyper-V integration?


  • Some additional information on this - I found what my initial problem was after doing some inspection of the 'tasks' that were created.  Currently the log LPAR2RRD_agent-<lpar2rrd host>-8162-load.txt is stating that my data is being sent to the lpar2rrd server successfully but I don't see anything on the actual server. I did a grep on all the log files for hyperv and HYPERV and the server that was pushing and nothing is there even though it is connecting successfully.

    No folders in the data directory correspond to the server host name (upper or lower case) so it is a bit confusing - not sure how to troubleshoot this if one is saying successful and the other has no record of anything.  All my other servers are updating with no issues to include stand-alone linux.

    If anyone knows where to look to troubleshoot what is going on, that would help.  My config file is also set to no Active Directory and No additional Monitored servers other than the local host.  I assume that this is 'MODE 1' which is in the Windows Server Log.
  • Always good to have more information - I had to restart my lpar2rrd server this AM for maintenance - when I had the app down, I did check the log on the Windows Server before starting it up again to see what it looked like to confirm if it was actually sending data or not.

    There was an error in the log on the Windows Server that it could not connect to lpar2rrd server.  I saved a copy of this error file.

    Once I got the lpar2rrd server running again, I waited (as the Windows Server uploads a file every 5 minutes) to see the next cycle log and it again said successfully uploaded the file to the lpar2rrd server.  I did verify with telnet that I can connect to the 8162 port of the lpar2rrd server from this Windows Host so it would appear that everything is working correctly but I still don't see any HyperV or Windows objects in the main menu.  There are no errors in the logs (at least not recently).  I know it is getting to the correct server since the 'telnet' session I did caused an error in the log for a bad connection (the only log entry for that IP Address).

    I also checked the data folder to verify - no HyperV or Windows or anything in there - so a bit lost on where to look next.  No errors in logs, everything is saying that it is working correctly but nothing about the server sending the data in the logs either.  Reboot didn't work either....
  • So the answer to this question was I didn't read all of the instructions.  I had already installed lpar2rrd (and store2rrd) so I thought that I had everything running.  Because of that I didn't look at the server installation instructions completely for lpar2rrd Hyper-V because they started out the same as what I had already done.  There is one step that was different though, you have to put in a cron entry for Hyper-V support.  Once I put that into the cron and it ran, everything was fixed and all the data that was being uploaded to the server was included.  

    So just have to read all the instructions on each part that you work with and it will work like a charm.
Sign In or Register to comment.