LPAR2RRD 6.02 data graphs missing

Hi,

Probably this has been asked already, but I have data graphs gaps like the one below, but only for certain servers and LPAR's. I've seen some topics state that may be due to HMC TZ configuration.


Comments

  • Hi,

    yes.
    run this under lpar2rrd
    ./bin/sample_rate.sh

    HMC time should be more less equal to "lslparutil time" in its output.
    When there is big difference then you have probably changed HMC TZ without rebooting the it.
    HMC reboot resolves it.

  • Hi Pavel,

    Thank you for the help. It seems that the ./bin/sample_rate.sh works only if the HMC is using SSH for connection, but I have configured it only via REST API.

    When I do "date" for the HMC and "lslparutil time" it seems they are aligned.
    lslparutil -r all -m XXXXXXXXXXX
    time=08/15/2019 04:30:00,event_type=sample,resource_type=sys,sys_time=08/15/2019 04:30:01,primary_state=Started

    HMC date
    Thu Aug 15 04:31:07 CDT 2019

  • Hi,

    send us logs. It seems like one of the data load takes more than 20 minues which should not happen.

    cd /home/lpar2rrd/lpar2rrd # or where is your LPAR2RRD working dir
    grep -v 'passw' etc/web_config/hosts.json > tmp/hosts.txt;
    tar cvhf logs.tar logs tmp/*txt tmp/*json tmp/restapi/*;
    gzip -9 logs.tar;

    Send us logs.tar.gz via https://upload.lpar2rrd.com
  • Hi,

    Thanks again, I've uploaded the logs.

    A thing to note is that my LPAR2RRD server is running also in completely different TZ than the monitored servers. Not sure if this makes any difference.
  • @tmarinov

    did you ever find what was wrong?  I'm having the same problem.  time appears correct but lpar2rrd is not liking it.  It thinks there is a 1 hour difference. reboot of the hmc did not help
  • @jjsk1

    Hello,

    do the same as tmarinov did. Send us logs and we'll take a look into this issue. 

    cd /home/lpar2rrd/lpar2rrd # or where is your LPAR2RRD working dir
    grep -v 'passw' etc/web_config/hosts.json > tmp/hosts.txt;
    tar cvhf logs.tar logs tmp/*txt tmp/*json tmp/restapi/*; 
    gzip -9 logs.tar;

    Send us logs.tar.gz via https://upload.lpar2rrd.com
  • edited September 4
    @jan_dvorak don't think I need to send logs at this time

    I found that rest API perl script pulls time from https://<hmc>/rest/API/pcm/preferences

    our hmc show one HR off utc-5 instead of utc-4 at that url no matter how many times we reboot or reset time setting.  hmc cli has the correct local time.  looks like a bug in hmc to me.  looking into this.. 
  • fyi ust in case some one sees this..

    upgrading hmc from 8.7 to v9  fixed the time problem at https://<hmc>/rest/api/pcm/preferences  lpar2rrd does not complain anymore
Sign In or Register to comment.