IBM i agent 1.1.5 expired

Hello,

Today, the IBM i agent 1.1.5 stopped working/doesn't want to start on one of our 7.3 lpars.
When starting manually, I get a message stating the agent has been expired, although it was only installed last month , in fact 2019-02-18 and license was accepted back then granting until 2020-02-18.

joblog:
ER:RTV_SYSSTS Expiration date of this client is 2019-04-30
ER:RTV_SYSSTS Please download new version of i5/OS client.
ER:RTV_SYSSTS i5/OS client ended.                         

After re-accepting the license:
OK:CL_ACCEPT Expiration date of this client is 2020-04-30
OK:CL_ACCEPT ended.   

Unfortunately, the agent keeps saying it is expired. RTV_SYSSTS & SND_SYSSTS jobs do no start.

I already tried reinstalling the agent on that LPAR from a fresh download of the installation package on the site, but no luck with that. Still same issue.    

Any ideas on what the cause could be and/or where to start troubleshooting?
Thanks in advance

Comments

  • I have noticed the same problem yesterday.
  • edited May 2
    Hi,

    there is hardcoded expiration time (30th of Apr 2019), then the agent does not start. Running agents are not affected.

    It must be reinstalled with a new version. Only users of the free edition are affected.

     

    We will release 1.1.6 version today evening, it will work for next couple of years.

     

    I apologize, we forgot about it, actual v1.1.5 is there for couple of years, we expected more versions coming meanwhile, each with prolonged expiration time.


  • Hi Pavel,

    any release date right no for new 1.1.6 Version?

    Many thanks

  • Hi,

    it has been just released.
  • Hi,
    is there a requisite for OS version for 1.1.6 IBM i agent?
    seem not working on a V6R1, unable to dspsavf the save file, CPF3743.
    any chance to have a V6R1 compatible agent?
    Thanks in advance
  • Hi,

    we are not aware of that, let us check it out, we will let you know soon.
  • Hi,

    We've reinstalled agent 1.1.6 and still getting 
     Mensaje . . . . :   ER:RTV_SYSSTS Expiration date of this client is 
       2019-04-30.                                                       
    although we've accepted license again

    Rgds,
  • Hi,

    this should not be, looks like you have there still 1.1.5 in place
    Are you sure that you used the right version for upgrade?
    Have you cleared up original one?

    CLRSAVF FILE(QGPL/LPAR2RRD)
    CLRLIB LIB(LPAR2RRD)


  • You're right the CL program we use to update had an error, we've corrected it in order to clear all library and savf copies before updating
    rgds,
    Jaume.
  • Hi,

    regarding V6R1 support. Your right, it is not compilled with its support.
    we will re-compile it and let you know.

  • Hi,

    1.1.6 package with V6R1 support just re-placed original 1.1.6 on our download sites.
    Download it again and upgrade.
  • yeah thank you :smile:

  • so bad, even introverts are here (see my topic nearby with quick installation script)
  • Hi pavel ... we have the same problem with 1.1.7 : 

    OK:CL_ACCEPT Expiration date of this client is 2020-10-08.
    ER:RTV_SYSSTS Expiration date of this client is 2019-04-30.

    Could you please have a look ?
    Regards
    Jürgen

  • hi,

    it should not be, can you accept license again?
    go menu --> accept license


  • hi Pavel ... after I did a DLTLIB LPAR2RRD instead of CLEARLIB LPAR2RRD prior to installation it worked ...
    Dont know whether that was the reason or I did something wrong before.
    No it works
    Thanks and regards
    Jürgen
Sign In or Register to comment.