Error show ASP tabs with IBM i OS agent (free version)


The ASP Used, Free and Data tabs show no data. In addition the annual graph indicates: Error happened Check  - $$ LPAR2RRD_HOME $$ / logs / error-cgi.log  - Web server error Can anyone help?

Comments

  • Hi,

    1. has that ever worked?
    2.
    cd /home/lpar2rd/lpar2rrd
    tail -f logs/error-cgi.log

    and refresh the graph in the GUI (Ctrl-F5)

    3. are only yearly graphs affected?
    if you have installed that OS agnet it then wait 1 day, it will appear there


  • When reviewing the log that you comment, it indicates the following:
    
    tail -f logs/error-cgi.log
    substr outside of string at /home/lpar2rrd/lpar2rrd/bin/detail-graph-cgi.pl line 13174.
    Use of uninitialized value in addition (+) at /home/lpar2rrd/lpar2rrd/bin/detail-graph-cgi.pl line 13174.
    substr outside of string at /home/lpar2rrd/lpar2rrd/bin/detail-graph-cgi.pl line 13174.
    Use of uninitialized value in addition (+) at /home/lpar2rrd/lpar2rrd/bin/detail-graph-cgi.pl line 13174.
    Tue Jan 15 09:37:35 2019: hmccibtc1:Server-9119-FHB-SN844FE67:C12186PR-844FE67:cap_used:y:h:0:0.645 : hmccibtc1 : Multi graph ASP Mem rrdtool error : ERROR: mmaping file '/home/lpar2rrd/lpar2rrd/data/Server-9119-FHB-SN844FE67/hmccibtc1/C12186PR-844FE67--AS400--/ASP/': No such device at /home/lpar2rrd/lpar2rrd/bin/detail-graph-cgi.pl line 13293.
     /home/lpar2rrd/lpar2rrd/bin/detail-graph-cgi.pl:13296
    Tue Jan 15 09:37:35 2019: hmccibtc1:Server-9119-FHB-SN844FE67:C12186PR-844FE67:cap_used:y:h:0:0.645 : Graph rrdtool error : print_png : file does not exist : /var/tmp/lpar2rrd-hmccibtc1-Server-9119-FHB-SN844FE67-C12186PR-844FE67-cap_used-y-h-23121.png /home/lpar2rrd/lpar2rrd/bin/detail-graph-cgi.pl:577
    Tue Jan 15 09:37:35 2019: hmccibtc1:Server-9119-FHB-SN844FE67:C12186PR-844FE67:cap_used:y:h:0:0.645 : Cannot open  /var/tmp/lpar2rrd-hmccibtc1-Server-9119-FHB-SN844FE67-C12186PR-844FE67-cap_used-y-h-23121.png: No such file or directory/home/lpar2rrd/lpar2rrd/bin/detail-graph-cgi.pl:616
    substr outside of string at /home/lpar2rrd/lpar2rrd/bin/detail-graph-cgi.pl line 13174.
    Use of uninitialized value in addition (+) at /home/lpar2rrd/lpar2rrd/bin/detail-graph-cgi.pl line 13174
    
    
    It seems that the problem is the following:
    Use of uninitialized value in addition (+) at /home/lpar2rrd/lpar2rrd/bin/detail-graph-cgi.pl line 13174.
    
    
    The product has been running for a couple of months, but from the beginning we have not managed to load the ASP USED / FREE tab in any of its graphics, the graphic appears but blank.
    In addition, the annual chart indicates:
    
    'Error happened Check  - $$ LPAR2RRD_HOME $$ / logs / error-cgi.log  - Web server error'. 
    
    NOTE: Only correct an error in the statement of my post, since the ASP DATA tab does show the graphs with data correctly, like ASP IOPS.
  • Hi,

    1. IBM i OS agent version, you can find it in menu --> LPAR2RRD item --> data check --> IBM i

    2.
    ls -l /home/lpar2rrd/lpar2rrd/data/Server-9119-FHB-SN844FE67/hmccibtc1/C12186PR-844FE67--AS400--/ASP/

  • Attach a TXT document. Thanks
Sign In or Register to comment.