install latest lpar2rrd-server on linux sles 15 server - rrd perl modul missing

Hi there,

we have a brand new sles 15 linux server and tried to install the latest lpar2rrd-server version.

When I ran the script I got following missing required perl module:

ERROR: Perl module has not been found: RRDp

Before I ran following CPAN command to install the rrd perl module:
$ perl -MCPAN -e 'install RRD::Simple'                          
Reading '/root/.cpan/Metadata'
  Database was generated on Sun, 18 Nov 2018 20:17:02 GMT
RRD::Simple is up to date (1.44).

What's wrong here and how can I fix this to get the lpar2rrd server running.

Thank you for your support!


  • You need these 2 packages

    # rpm -qa | grep rrdtool

    RRDp module contans the second package.
    Check instal manual for more ...

  • Hi Pavel,
    I think that's the main problem. I got only following packages installed:
    $ rpm -qa | grep rrdtool

    because there are no other zypper packages with the name rrdtool that makes for me sense to install:

    $ zypper se rrd
    Loading repository data...
    Reading installed packages...

    S  | Name                 | Summary                                                         | Type  
    i  | librrd8              | Round Robin Database tool library                               | package
       | lighttpd-mod_rrdtool | Lighttpd module to feed rrdtool databases                       | package
       | python-pyrrd         | An Object-Oriented Python Interface for RRD                     | package
    i+ | rrdtool              | Round Robin Database Tool to store and display time-series data | package
    i+ | rrdtool-devel        | RRDtool header files                                            | package

    $  zypper se perl | grep -i rrd

    Do you have any docs how to install the perl rrd modul, because for me it looks like that on SLE 15 there is no rrdtool-perl package

  • what about older rrdtool package on SLE? Would be there rrdtool-perl one?

    if not then take the package from whenever else and install it.
  • Check this to really assure it is not there:

    find / -name RRDp\*
  • Hello,

    i just found this one for OpenSuse:

    Please try to find perl-rrdtool with zypper

  • Hi Jirka,
    I didn't find any perl-rrdtool with zypper and I really don't like to install on my future production SLE server an rpm-packages from the internet

  • Hi,

    then we have no solution for you, ask SuSE to provide that package ...
  • okay, thank you I will. maybe that fact is something you can add to the documentation of the required packages on SLE 15?
Sign In or Register to comment.