Troubleshooting connectivity problems to DataDomain appliance


I'm trying to connect to a DataDomain appliance, for which I've followed all steps:
- testing the TCP connection over port 22 - OK;
- created stor2rrd user on the appliance (user role) - Done;
- imported the SSH-RSA key inside DataDomain (per instructions) - location: /home/stor2rrd/.ssh/ ;
- encrypted the password on the server side;
- modified and saved etc/storage-list.cfg file;

Data Domain OS

The problem is when I run:
./bin/ DataDomain_Alias

TCP connection to "my_IP" on port "22" is ok
ssh -o ConnectTimeout=80 -o StrictHostKeyChecking=no -o PreferredAuthentications=publickey -o SendEnv=no -q stor2rrd@my_IP  "system show all"
  connection failed!!

The question is this: is there a log that will show me why the connection fails?

Please advise.

Sincerely yours,
Alex H.


  • STOR2RRD version: 2.30
  • Hi,

    su - stor2rrd
    ssh stor2rrd@my_IP  "system show all"

  • Thanks!
    Based on this I was able to determine the cause: the hostname defined inside the public key; once I've changed that to IP, it worked just fine.
Sign In or Register to comment.