Error: password cannot be decoded


I'm following the documentation to setup the monitoring for a VNXe storage:
- installed UnisphereCLI - done!
- created the user on the storage side - Operator ONLY - done!
- tested the account by Log in on the storage side - done!
- tested the connection and Accepted and Stored the certificate - done!
- encrypted the password for stor2rrd user
- updated/modified etc/storage-list.cfg to reflect the changes

from /home/stor2rrd/stor2rrd I run: ./bin/ and I get the message:

Error: password cannot be decoded
  connection failed!!

Can you please help me?


  • If you are on AIX then most probably probably this path missing in etc/stor2rrd.cfg and PERL5LIB, place it at the end:

  • Thanks for the reply, but I'm not in AIX; for Unity and VNXe I was "forced" to use CentOS 6.9: UnisphereCLI for Unity and VNXe works only in Linux or Windows.

    I've placed the path you suggested at the end of PERL5LIB, but it didn't make a difference.

    Is there a file to erase, so I can recreate the encrypted password, or do I have to start from scratch?
  • do you have thi sinstalled?
    rpm -qa| grep -i TimeDate         

  • Yes.

    [stor2rrd@storMan stor2rrd]$ rpm -qa| grep -i TimeDate

  • This is mostly caused by some perl module which cannot be found, test it by this:

    Replace XXXX by your password, do you get plain text password as output of below?

    cd /home/stor2rrd/stor2rrd
    . etc/stor2rrd.cfg
    export PERL5LIB=bin:$PERL5LIB
    $PERL -I. -MXorux_lib -e 'print Xorux_lib::unobscure_password("'XXXXX'")'

  • I'm getting:
    -bash: !'": event not found

    where ! is the last character in the password.

    Now, if in your expression I replace " with ', I get this:

    Bareword found where operator expected at -e line 1, near "XXXX"
            (Missing operator before XXXX ?)
    syntax error at -e line 1, near "XXXXX"
    Execution of -e aborted due to compilation errors.

  • For Unity and VNXe, I have to use special characters and in this case I've used this '!'
  • use underscore or dash instead for example.

  • aharabagiu
    edited November 2017
    This test works fine, but still fails with the same error.

    On Linux, does Perl LWP module have to be at 6.x (currently is 6.02), or it works with 5.83 as well? (i'm connecting to EMC storage ONLY)
  • is this working?

    cd /home/stor2rrd/stor2rrd
    . etc/stor2rrd.cfg
    export PERL5LIB=bin:$PERL5LIB
    $PERL -I. -MXorux_lib -e 'print Xorux_lib::unobscure_password("'XXXXX'")'
  • Yes, this sequence works.
    However, fails...
Sign In or Register to comment.