EMC VNX 5200 - Cannot install NaviCLI-Linux-32-x86-en_US-

Hi folks,

I tried to add my EMC VNX 5200 to stor2rrd with the virtual appliance but I am blocked here and have no solution :

[root@VIRMoSAN01 ~]# rpm -i NaviCLI-Linux-64-x86-en_US-
error: Failed dependencies:
        libc.so.6 is needed by NaviCLI-Linux-64-x86-en_US-
        libc.so.6(GLIBC_2.0) is needed by NaviCLI-Linux-64-x86-en_US-
        libc.so.6(GLIBC_2.1) is needed by NaviCLI-Linux-64-x86-en_US-
        libc.so.6(GLIBC_2.3) is needed by NaviCLI-Linux-64-x86-en_US-
        libdl.so.2 is needed by NaviCLI-Linux-64-x86-en_US-
        libdl.so.2(GLIBC_2.0) is needed by NaviCLI-Linux-64-x86-en_US-
        libdl.so.2(GLIBC_2.1) is needed by NaviCLI-Linux-64-x86-en_US-

Is there a way to install it ? In principle, virtual appliance should contain all dependencies ?


  • Hi,

    I have just tried it, it is ok with the same package.
    What is your appliance version? It is noted on the bottom of its root web page:
    open web page http://<your hostaname>/

    [root@xorux]# rpm -i NaviCLI-Linux-64-x86-en_US-
    Please enter the verifying level(low|medium|l|m) to set?
    Setting low verifying level
    root@xorux]# rpm -qa| grep libgcc

  • Hi thanks for your response :

    [root@VIRMoSAN01 ~]#  rpm -qa| grep libgcc

    I was in 1.30 and upgraded yesterday to last version 1.35-1
  • Ok I found the issue.

    We need to insall :smile: 
     yum install glibc-utils.x86_64 compat-glibc-headers.x86_64 glibc.i686

  • I well, I think that this oneis missing at your appliance

     yum install glibc.i686

  • BTW what is youir appliance version:
    grep "Virtual Appliance version" /var/www/html/index.html| sed -e 's/^.*Virtual Appliance version/Virtual Appliance version/' -e 's/is brought to you by.*//'

    Looks like you have older appliance when there was not support for VNX yet.

  • Yes it is. So I have to instlal glin utils.
  • Sorry glib utils.
  • is it working with installed glibc.i686?
    It is something what helped in this thread and it is a difference between your version of the appliace and the actual one

Sign In or Register to comment.