Brocade SAN Switch 300, configure, load but not appear in http:///stor2rrd

edited December 2016 in SAN
Hi 
I have configure in san-list.cfg in the virtual appliance for version 1.35 free

SNMP_VERSION=3
157.165.162.77:snmpuser3:BRCD:Penbrfc1
SNMP_PORT=161

config_check.sh

=========================
SWITCH: 157.165.162.77
=========================
Type         : BRCD
DestHost     : 157.165.162.77
Version SNMP : 3
SecName      : snmpuser3
Community    : snmpuser3
SNMP port    : 161
Switch name  : penbrfc1
STATE        : CONNECTED!

I run load.sh in/home/stor2rrd/stor2rrd and get the following files inside /home/stor2rrd/stor2rrd/data/penbrfc1

config.cfg                              port11.first  port14.rrd    port18.first  port20.rrd    port24.first  port4.rrd    port8.first
fabric.txt                              port11.rrd    port15.first  port18.rrd    port21.first  port24.rrd    port5.first  port8.rrd
penbrfc1_sanperf_20161201_1456.out.tmp  port12.first  port15.rrd    port19.first  port21.rrd    port2.first   port5.rrd    port9.first
penbrfc1_sanperf_20161201_1457.out.tmp  port12.rrd    port16.first  port19.rrd    port22.first  port2.rrd     port6.first  port9.rrd
PHYS_PORTS.cfg                          port13.first  port16.rrd    port1.first   port22.rrd    port3.first   port6.rrd    PORTS.cfg
port10.first                            port13.rrd    port17.first  port1.rrd     port23.first  port3.rrd     port7.first  SAN-BRCD
port10.rrd                              port14.first  port17.rrd    port20.first  port23.rrd    port4.first   port7.rrd    total_summary.rrs

I have configure the necessary according to the installation steps in http://www.stor2rrd.com/install.htm?1.2

However I don't see any SAN switch name 'penbrfc1'  at the left pane of the hierarchy tree?



Anything that is missing?

Thanks.






Comments

  • I have the exact same problem. I'm missing the SAN button in the left pane after everything is working now. 
  • ok, I see the problem, SAN switche is not in menu, pls this output:
    cd /home/stor2rrd/stor2rrd
    date
    ls -l tmp/menu.txt
    grep SAN tmp/menu.txt| wc -l

    If tmp/menu.txt timestamp is not from today then
    ./load.sh html
    Ctrl-F5 in the GUI once it finishes

    when nothing then logs pls:

    Note a short problem description in the text field of the upload form.

    cd /home/stor2rrd/stor2rrd          # or where is your STOR2RRD working dir
    find data -exec ls -ld {} \; > tmp/list_data.txt
    tar cvhf logs.tar logs etc tmp/*txt tmp/*out # do not miss "h" option in tar
    gzip -9 logs.tar

    Send us logs.tar.gz via https://upload.stor2rrd.com



  • Thank you Pavel, that solved my problem.
  • Pls more details. Have you just added the 1st switch into stor2rrd?
    Then it will appear in the GUI after next schedulled load.sh from crontab and refresh of the web browser.
    2 issue could be
    - not running load.sh after switch addition
    - not refreshed browser

    can you confirm that it could be your case just to be sure that it works as expected.
  • Yes, I first added 1 switch to the san-list.cfg file. After that I checked it with config_check.sh to be sure that the switch can be connected. Then I run the load.sh.

    After that I added the additional 3 switches, run config_check.sh and load.sh again but no "SAN SWITCH" entry showed up in the left pane.

    Now I have the problem, that the graph of the 1st switch is empty and the other ones having error messages. I assume it is because of this error while running load.sh:

    Thu Dec  1 16:21:08 2016: Could not find port1 file: /home/lpar2rrd/stor2rrd/data/SW-RZ2-703/port1.rrd ./bin/san.pl:1608
    Thu Dec  1 16:21:08 2016: Could not find port2 file: /home/lpar2rrd/stor2rrd/data/SW-RZ2-703/port2.rrd ./bin/san.pl:1608
    Thu Dec  1 16:21:08 2016: Could not find port3 file: /home/lpar2rrd/stor2rrd/data/SW-RZ2-703/port3.rrd ./bin/san.pl:1608
    Thu Dec  1 16:21:08 2016: Could not find port4 file: /home/lpar2rrd/stor2rrd/data/SW-RZ2-703/port4.rrd ./bin/san.pl:1608

    But I think it is better to open a new thread for this issue?
  • edited December 2016
    Correction, now I have Data on the 1st switch. The other 3 have still the same problem, that the portX.rrd files are missing.

    Edit: Nevermind, now all data showed up.
  • wait a bit, they will come up, some data has to be downloaded at first what might take 10 - 15 mins.
  • Thanks everyone.  I left it overnight running. Today I am able to see it appear. Just to be patient.
Sign In or Register to comment.