LPAR2RRD - v7.10-1 broken graphs for vm's in OracleVM

Hello,
when i try to view a VM in OracleVM

i get this error:

(Software error:
Can't use string ("0") as a HASH ref while "strict refs" in use at /home/lpar2rrd/lpar2rrd/bin/detail-cgi.pl line 5214.
For help, please send mail to the webmaster (root@localhost), giving this error message and the time and date of the error)

in that moment when i try click to next tab like CPU%/MEM/NET/DISK i cann't

in version 7.00-2 it worked and I could view the charts


in log load_oraclevm.log i got also communicate:
installing WWW : install-html.sh oraclevm
Host identif   : Linux
timestamp      : Thu May 27 07:01:28 CEST 2021
Menu           : no menu refresh for oraclevm

Please help repair it

Comments

  • Hello,

    please upgrade your LPAR2RRD.

    New version download link: https://www.lpar2rrd.com/download-static/lpar2rrd-7.11-18.tar

    Upgrade docu: https://lpar2rrd.com/upgrade.php

    Let us know.

  • Hello,
    Thank you very much for the tip.
    I will update the application as soon as possible and let you know.


  • Hello,
    after installation and execute:
     lpar2rrd]$ ./load.sh 2>&1 | tee logs/load.out-initial

    i got these information:
    Resource Configuration Advisor has been started on the background
    It might take about an hour in big environments till it finishes
    
    An error occured in lpar2rrd, check /home/lpar2rrd/lpar2rrd/logs/error.log and output of load.sh
    
    $ tail -103 /home/lpar2rrd/lpar2rrd/logs/error.log
    
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapperJSON.pm line 12.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapperJSON.pm line 12.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapper.pm line 5.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapper.pm line 5.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/LoadDataModule.pm line 7.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/LoadDataModule.pm line 7.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/lpar2rrd.pl line 18.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/lpar2rrd.pl line 18.
    Socket version 1.97 required--this is only version 1.82 at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    ...
    nohup: ignoring input
    [Mon May 31 06:50:31 2021] prediction.pl: Socket version 1.97 required--this is only version 1.82 at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    [Mon May 31 06:50:31 2021] prediction.pl: BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    [Mon May 31 06:50:31 2021] prediction.pl: Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    [Mon May 31 06:50:31 2021] prediction.pl: BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    [Mon May 31 06:50:31 2021] prediction.pl: Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapperJSON.pm line 12.
    [Mon May 31 06:50:31 2021] prediction.pl: BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapperJSON.pm line 12.
    [Mon May 31 06:50:31 2021] prediction.pl: Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapper.pm line 5.
    [Mon May 31 06:50:31 2021] prediction.pl: BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapper.pm line 5.
    [Mon May 31 06:50:31 2021] prediction.pl: Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/prediction.pl line 12.
    [Mon May 31 06:50:31 2021] prediction.pl: BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/prediction.pl line 12.
    nohup: ignoring input
    Socket version 1.97 required--this is only version 1.82 at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapperJSON.pm line 12.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapperJSON.pm line 12.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapper.pm line 5.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapper.pm line 5.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/daily_lpars_count.pl line 6.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/daily_lpars_count.pl line 6.
    ...
    Socket version 1.97 required--this is only version 1.82 at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/gcloud-genmenu.pl line 12.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/gcloud-genmenu.pl line 12.
    Socket version 1.97 required--this is only version 1.82 at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/azure-genmenu.pl line 12.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/azure-genmenu.pl line 12.
    nohup: ignoring input
    nohup: ignoring input
    date end all   : Mon May 31 06:50:52 CEST 2021
    heatmap        : (Power) set cpu utilization for 0 lpars
    heatmap        : (Power) set cpu utilization for 0 pools
    heatmap        : (Power) set memory utilization for 0 lpars
    heatmap        : (Ovirt) set cpu utilization for 248 vms
    heatmap        : (Ovirt) set memory utilization for 248 vms
    heatmap        : (Ovirt) set cpu utilization for 12 servers
    heatmap        : (Ovirt) set memory utilization for 12 servers
    heatmap        : (ORACLEVM) set cpu utilization for 54 vms
    heatmap        : (ORACLEVM) set cpu utilization for 13 servers
    heatmap        : end Mon May 31 06:50:55 2021


    And now i don't have any data in vmware ovirt oraclevm etc.


    What i have to do now?

  • in log file error.log-vmware:
    Socket version 1.97 required--this is only version 1.82 at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapperJSON.pm line 12.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapperJSON.pm line 12.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapper.pm line 5.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/PowerDataWrapper.pm line 5.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/find_active_lpar.pl line 12.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/find_active_lpar.pl line 12.
    Use of uninitialized value $vcenter_id in concatenation (.) or string at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 2634.
    Use of uninitialized value $vcenter_id in concatenation (.) or string at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 2634.
    Use of uninitialized value $vcenter_id in concatenation (.) or string at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 2634.
    Use of uninitialized value $vcenter_id in concatenation (.) or string at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 2634.
    Use of uninitialized value $vcenter_id in concatenation (.) or string at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 2715.
    Use of uninitialized value $vcenter_id in concatenation (.) or string at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 2715.
    Use of uninitialized value $server_name in substitution (s///) at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 3167.
    Use of uninitialized value $server_name_space in length at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 3171.
    Use of uninitialized value $server_name in substitution (s///) at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 3172.
    Use of uninitialized value $server_name in substitution (s///) at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 3173.
    Use of uninitialized value $managedname in concatenation (.) or string at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 3181.
    Use of uninitialized value $server_name in concatenation (.) or string at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 3210.
    Use of uninitialized value $server_name in substitution (s///) at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 3167.
    Use of uninitialized value $server_name_space in length at /home/lpar2rrd/lpar2rrd/bin/heatmap.pl line 3171.
    and the passage repeats over and over again from "Use of uninitialized value..."

    in log file error.log-oraclevm only:
    Socket version 1.97 required--this is only version 1.82 at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/orvm-api2json.pl line 8.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/orvm-api2json.pl line 8.
    Socket version 1.97 required--this is only version 1.82 at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/orvm-api2json.pl line 8.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/orvm-api2json.pl line 8.
    Socket version 1.97 required--this is only version 1.82 at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/orvm-api2json.pl line 8.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/orvm-api2json.pl line 8.

    in log file error.log-ovirt only:
    Socket version 1.97 required--this is only version 1.82 at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/ovirt-db2json.pl line 7.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/ovirt-db2json.pl line 7.
    Socket version 1.97 required--this is only version 1.82 at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm line 33.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/HostCfg.pm line 57.
    Compilation failed in require at /home/lpar2rrd/lpar2rrd/bin/ovirt-db2json.pl line 7.
    BEGIN failed--compilation aborted at /home/lpar2rrd/lpar2rrd/bin/ovirt-db2json.pl line 7.

    and etc in other log files
  • Hi,

    1. lpar2rrd version
    2. ls -l /usr/opt/perl5/lib*/*/IO/Socket/IP.pm

  • Hello,
    1.
    I have this: https://www.lpar2rrd.com/download-static/lpar2rrd-7.11-18.tar

    2.
    $ ls -l /usr/opt/perl5/lib*/*/IO/Socket/IP.pm
    ls: cannot access /usr/opt/perl5/lib*/*/IO/Socket/IP.pm: No such file or directory
    $ ls /usr/opt
    ls: cannot access /usr/opt: No such file or directory

    but in this place i have perl
    /usr/lib64/perl5/

     i don't have IP.pm:
    $ ls /usr/lib64/perl5/IO/Socket/
    INET.pm  UNIX.pm


    i have IP.pm 
    /home/lpar2rrd/lpar2rrd-7.10-1/dist/lib/IO/Socket/IP.pm
    /home/lpar2rrd/lpar2rrd-7.11-18/dist/lib/IO/Socket/IP.pm
    /home/lpar2rrd/lpar2rrd/lib/IO/Socket/IP.pm


  • Hi,

    are you on Linux?
    rpm -qa| grep -i socket


  • edited June 2
    Hello,
    yes
    Centos 6.10
    # rpm -qa| grep -i socket
    perl-IO-Socket-SSL-1.31-3.el6_8.2.noarch

  • edited June 11
    Hello,
    I hope @Pavel You will find a final solution to this problem soon but temporary as a workaround i had to back to the LPAR2RRD version7.00-2 and lpar2rrd work good
  • ok, CentOS 6, try to upgrade to perl-Scosket to 1.97, here is an example from CentOS 7 how it should look like, perhaps only first packe is significant

    perl-Socket-2.010-4.el7.x86_64
    perl-IO-Socket-IP-0.21-5.el7.noarch
    perl-IO-Socket-SSL-1.94-7.el7.noarch




  • we have just deployed CentOS 6, we will test it and let you know ...

  • Hello,
    it is great that You test with me on CentOS 6, i will try in my server also upgrade this package, but like i remember i tried this.
    I'll let you know about my results.

    P.S. 
    For now i can't upgrade CentOS 6. 
  • i have this:
    # rpm -qa | grep -i perl | grep -i socket
    perl-IO-Socket-SSL-1.31-3.el6_8.2.noarch
    perl-Socket6-0.23-4.el6.x86_64

    it is available from repository:
    perl-IO-Socket-INET6.noarch : Perl Object interface for AF_INET|AF_INET6 domain
                                : sockets
    perl-IO-Socket-Multicast.x86_64 : Perl library for sending and receiving
    perl-IO-Socket-SSL.noarch : Perl library for transparent SSL
    perl-Log-Log4perl-Appender-Socket-UNIX.noarch : Log4perl appender for writing to
                                                  : UNIX domain sockets
    perl-Danga-Socket.noarch : Event loop and event-driven async socket base class
    perl-IO-FDPass.x86_64 : Pass a file descriptor over a socket
    perl-IO-Socket-Timeout.noarch : IO::Socket with read/write timeout
    perl-Protocol-WebSocket.noarch : WebSocket protocol
    perl-Socket-GetAddrInfo.x86_64 : RFC 2553's "getaddrinfo" and "getnameinfo"
    perl-Socket-Netlink.x86_64 : Interface to Linux's PF_NETLINK socket family
    perl-Socket6.x86_64 : IPv6 related part of the C socket.h defines and structure


  • Hi,

    upgrade to this version and let us if the problem is fixed

  • Hi, 
    First thanks for trying help.
    I installed today 7.20-2 version and for first look i think it work but i will wait some time and checked again then i give you response
  • Hello,
    I checked today and it work good.
    Thank You very much
Sign In or Register to comment.