No SAN switchs in the interface

The SAN switchs are appearing in the Health Status, but clicking on them does nothing
And no San Switch BNA in the left Menu
We were using version 2.8, upgraded to 7 and still didn't fix the issue


  • Hi,

    Send us logs. 
    Note a short problem description in the text field of the upload form.

    cd /home/stor2rrd/stor2rrd # or where is your STOR2RRD working dir
    tar cvhf logs.tar logs tmp/*txt
    gzip -9 logs.tar

    Send us logs.tar.gz via
  • Hi Roy,

    Connection is fine but BNA does not provide data for ports.
    We have already seen it a few times.
    This what helped :

    1. BNA restart
    2. re-creation of stor2rrd user in BNA and re-discovering switches

    Go for 1 option and wait an hour.
    If no joy then try 2.
  • Hi Karel,

    Tried both options above, completely removed the switchs and BNA from stor2rrd and rediscovered them... waiting one hour between each action.
    Not fixed yet.

    Any other options?

    Thank you
  • I still see all those errors during the load

    Fri Dec 11 10:51:50 2020: Could not find port1-4 file: /stor2rrd/stor2rrd/data/B8510-MAR-04-BNA/port1-4.rrd /stor2rrd/stor2rrd/bin/

  • Hi,

    here is a procedure provided by our user who had the same issue as you.
    Maybe this will help you as well.

    Switches discovered through BNA (and the entire switch subsection within the GUI) completely disappeared from STOR2RRD.
    Checked the BNA server and noticed that the MAIN SERVER under the Brocade Server Management Console was not started.
    Started the MAIN SERVER (process = dcmsrv.exe).
    Deleted a single fabric from BNA (left other fabrics as is).
    Rediscovered that same fabric from BNA.
    Waited a few hours and ran the load script.
    STOR2RRD populated ALL data into the GUI for all fabrics within that BNA instance (even though the rediscovery was only done on a single fabric).

  • Hi,

    We tried the above procedure, didn't fix it
    dcmsrv.exe was running, but we did restart BNA anyway
    Removed and rediscovered a fabric

  • Hi,

    cd /home/stor2rrd/stor2rrd # or where is your STOR2RRD working dir
    tail logs/error.log-<BNA IP or hostname>

    Do you see there new error messages like this one?
    Thu Dec 10 14:40:19 2020: ERROR : SWITCH : switchXY-BNA : Can't create PORTS.cfg and HEALTH_STATUS.txt! Ports not found!/stor2rrd/stor2rrd/bin/ :
    If so, then this issue is still not resolved.
    This error message means the BNA does not provide statistics for switch's ports.

    You can try to collect statistics by yourself, use these cURL commands for that:

    1. Logging in
    - set <BNA user>, <user password>, <BNA IP>, <BNA PORT>

    curl -ks -X POST -H "WSUsername:<BNA user>" -H "WSPassword:<user password>" -H "Accept:application/vnd.brocade.networkadvisor+json;version=v1" -i https://<BNA IP>:<BNA PORT>/rest/login

    2. realtime performance statistics for 1 FC switch
    - set <WStoken>, <switchWWN>, <BNA IP>, <BNA PORT>

    curl -ks -X GET -H "WStoken:<WStoken>" -H "switchWWN:<switchWWN>" -H "Accept:application/vnd.brocade.networkadvisor+json;version=v1" https://<BNA IP>:<BNA PORT>/rest/fcswitchstats

    3. Logging out
    - set <WStoken>, <BNA IP>, <BNA PORT>

    curl -ks -X POST -H "WStoken:<WStoken>" -H "Accept:application/vnd.brocade.networkadvisor+json;version=v1" -i https://<BNA IP>:<BNA PORT>/rest/logout

    Unfortunately we do not know any other solution how to resolve this issue. So you can contact your BNA support and ask them how to fix that. Create a ticket with them and provide them these cURL commands and their outputs.
    Let us know if they will provide you some proper fix or procedure how to fix that. Thanks!
  • Hi,

    I dont have the log files "error.log-<BNA IP or hostname>"
    None of the switchs are generating log files in /logs

    But I have these below error in the error.log file, for every switch

    Wed Dec 16 12:10:22 2020: Switch is not updated! /stor2rrd/stor2rrd/data/B8510-CLY-05-BNA/PORTS.cfg does not exists! Skip load total_summary.rrs No such file or directory/stor2rrd/stor2rrd/bin/ : No such file or directory

    For the curl commands, I am able to log in using the stor2rrd user and command 1 works fine

    But for command 2, I get this
    RSError [errorCode=4001, errorMsg=Token in header is null or empty]

    We are using BNA for EMC CMCNE version 14.4.5 build 16

  • Hi,

    error log of your BNA:

    ls -l /stor2rrd/stor2rrd/logs/error.log-sp02*

    In the second command you have to use "WStoken" which is generated in the first command.
  • Hi

    Yes I have the BNA server log and it contains lots of:
    Wed Dec 16 13:20:07 2020: ERROR : SWITCH : B6520-CLY-01-BNA : Can't create PORTS.cfg and HEALTH_STATUS.txt! Ports not found!/stor2rrd/stor2rrd/bin/ :

    Ok, it works better with the WStoken :)
    But only give me back this:

  • Hi,

    empty responseList means that your BNA just doesn't provide statistics for ports.
    We have already seen that a several times. Unfortunately we don't have any other solution than that i already wrote you. BNA is not our software.

    You can raise a ticket with your BNA support. Provide them cURL commands and outputs. This should be enough. Pls let us know if they will provide you some proper fix or procedure how to fix that. Thanks!
  • Thank you Karel,
    We will keep you posted if we are able to fix anything
  • Hi Karel, 
    An update on the subject: Reinstalling BNA solved the issue.
Sign In or Register to comment.