ER: Quit UnixTime protocol - possible regression with IBMi agent 1.1.5 ?

we are currently evaluating LPAR2RRD agent (v1.1.5) for monitoring IBMi partitions (OS version 7.2).
Agent fails on 2 test LPARs due to an error which was already reported and fixed for lower versions:

IF: C_SNDSTS  - protocol 5.3 UTF8 conv
IF: C_SNDSTS  - connection Established()
ER: Quit UnixTime protocol.
IF: C_SNDSTS - re-connect(). 
IF: C_SNDSTS  - connection Established()
ER: Quit UnixTime protocol.                                               

Nothing is written to /home/LPAR2RRD directory.
The installation was done exactly as documented.

Any ideas how to fix this problem or why it might appear even with a recent agent release?


  • 1. is there network visibility to lpar2rrd server?
    have you tried telnet test as per install docu?

    2. Has that agent ever worked or is it atempt to initial cfg?

  • 1. The telnet-test was performed and worked ok (command hanging and no error).
        If lpar2rrd listener is stopped on the server error code 3425 appears on IBMi side.
        But as soon as it is running again, the sequence of "ER: Quit UnixTime protocol" errors

    2. Both test runs were initial installations of the agent.

  • ok, there must be some issue on the lpar2rrd server side when both agents behave like that.
    pls send us logs
    Note a short problem description in the text field of the upload form.
    cd /home/lpar2rrd/lpar2rrd  # or where is your LPAR2RRD working dir
    tar cvhf logs.tar logs etc tmp/*txt 
    gzip -9 logs.tar
    Send us logs.tar.gz via

  • The problem has been resolved with excellent help from support.
    In fact this was not an agent but a server/backend issue.

    Somehow the server installation got messed up and the
    symlinks in <lpar2rrd home>/data/ did not point to the
    actual server data directories.

    This broken symlink problem can be fixed by removing
    affected symlinks and let the tool re-create them automatically.

  • francise
    edited April 2019
    Removed comment - off topic
Sign In or Register to comment.