SVC - some data missing

I migrated stor2rrd 7.30 installation to new system (Linux to Linux) and I have issues with one of storage: SVC. Configuration is presented but there is no performance data.

I removed all data for this SVC (from data, www, tmp) but it not helped.

In logs/error.log-SVC there is one repeated line:
Max. recursion depth with nested structures exceeded at /usr/lib64/perl5/vendor_perl/ line 278, at /opt/stor2rrd/bin/ line 902.

Could you help me with debugging it?

P.S. Another SVC works as expected.

Regards, Grzegorz


  • Hi,

    do you get same error by running this:
    perl -MStorable=nstore -e '$h->{$i}{a}{b}{c} = 0 while $i++<10000; nstore($h, "testfile")'

    what is your perl, older than 5.30?

    As a workaround,you can change the value of the limit into the file /usr/lib64/perl5/vendor_perl/Storable/¿ like below:
    # bisected by stacksize
    $Storable::recursion_limit = -1
      unless defined $Storable::recursion_limit;
    $Storable::recursion_limit_hash = -1
      unless defined $Storable::recursion_limit_hash;

  • Hi Pavel,

    Yes, We have RHEL 8.5 with perl 5.26 - default version. I've tried to upgrade it to 5.30 (using module streams), but a lot of dependency was missing. But your workaround with manually changed limit - works! Thank you!

    Regards, Greg
  • just a note for AIX users where does not exist with  perl-5.30.3-2 at least.

    in stor2rrd application directory (/home/stor2rrd/stor2rrd usually) open:

    vi bin/

    and put this behind line: use Storable qw(retrieve nstore);

    # Bug: Max. recursion depth with nested structures exceeded



Sign In or Register to comment.