LPAR2RRD OS-Agent (AIX) 6.00 and missing FS Tab

Hey guys, I noticed that on some machines the FS Tab isnt created:

AIX Agent 6.00 creates - lpar2rrd-agent-lpar2rrd.host-lpar2rrd-fs.txt. Data is transmitted to lpar2rrd, but the FS tab doesnt appear in lpar2rrd. Strange that on some Machines I have the FS tab. I tried to find some answers here in Forum but seems its just my problem. lpar2rrd 6.00 server runs on linux. All other data is collected and displayed perfectly well.

Switched to OS-Agent yesterday - before I collected nmon data.

Any help would be appreciated .. :-)



Comments

  • edited February 27
    Just to visualize - the right tab FS is what I partly miss on some LPARs
  • hello sirs,
    I have the same problem.
    I've found  in the log file error.log-daemon  (on lpar2rrd server logs directory) this message repeated for all the partitions without FS tab: 
    Thu Feb 28 16:06:04 2019: 192.168.70.237: not correct items count: 309, 8408-44E*...    omissis ..... :: : try return ok (1551365521)/home/lpar2rrd/lpar2rrd/bin/lpar2rrd-daemon.pl:670 :

    My lpar2rrd server run on aix server

    any ideas ?

  • hi,

    send us complete error line, support@lpar2rrd.com
  • Ahoj Pavel,

    I sent you (support@lpar2rrd.com) my linux lpar2rrd server logs entry with one of the issues above .. maybe it helps for further analysis.

    Thanks Lemmy
  • Hi,

    can you try this fix?

    http://download.lpar2rrd.com/patch/detail-cgi.pl.gz
    Gunzip it and copy to /home/lpar2rrd/lpar2rrd/bin (755, lpar2rrd owner)
    -rwxrwxr-x 1 lpar2rrd lpar2rrd 309440 Mar  1 09:24 detail-cgi.pl
    If your web browser gunzips it automatically then just rename it: mv detail-cgi.pl.gz detail-cgi.pl

    It is necessary to deploy new agent:
    http://download.lpar2rrd.com/patch/lpar2rrd-agent.pl.gz

    Let us know with the result, thanks.
  • edited March 1
    Hey Karel,

    replaced detail-cgi.pl and deployed new agent.

    FS tab still missing.

    I attach the log and change history.

    ============================================

    SORRY ... now after some 30min all FS TABS appeared ..

    GREAT JOB - thanks guys !!!

    Super .. - I am happy ... have a great weekend!

    Thanks so much

    Stefan



  • as per above on the lpar2rrd server


  • hello sirs,
    with the new agent and cgi , all partitions are working fine.
    Thanks for the solution.
    Best regards
    Lorenzo
  • What do I need to configure to get the "FS" tab on the dashboard, i never had that displayed since v4, now v5
    thanks
  • Upgrade lpar2rrd server and the OS agent to the v6+ versions, it is not supported in v5
  • aah. ok. I have one v6 already, but the case I am dealing with you already through my official email. :)
    thanks
  • its working now. thanks :)
Sign In or Register to comment.