Perl5 AIX Toolbox Version Compatibility

When we run our yum check-update command on our LPAR2RRD server we are getting output that Perl5 needs to be updated. Presently we are running the open source version that comes with the LPAR2RRD download (5.8.8-2). Yum wants to have us upgrade to the AIX Toolbox version of Perl5 (1:5.28.0-1). Noting this, I have a couple of questions:

1. Is the AIX Toolbox version compatible with the most recent version of LPAR2RRD? 
2. If so, and, we install it, are there any modifications that will need to be done to the Perl path in the lpar2rrd.conf file?

We were able to successfully update the rrdtool to the AIX Toolbox version, but want to make sure that there were no issues with doing the same with Perl5.


Keith Barth


  • Hi,

    yes it is compatible, just one thing needs to be done if you are at rrdtool 1.7
    under lpar2rrd account (replace $HOMELPAR by /home/lpar2rrd/lpar2rrd if you have it installed in this path)

      touch $HOMELPAR/lpar2rrd-cgi/mon.out
      chmod 777 $HOMELPAR/lpar2rrd-cgi/mon.out
      touch $HOMELPAR/bin/mon.out
      chmod 777 $HOMELPAR/bin/mon.out

  • When I tried the yum update to the new version of Perl5 (1:5.28.0-1) it failed on due to dependencies of the following packages:

     perl-TimeDate                               noarch                   1.20-1                       @/perl-TimeDate-1.20-1.aix5.1.noarch                               101 k
     perl-URI                                    noarch                   1.58-1                       @/perl-URI-1.58-1.aix5.1.noarch                                    255 k
     perl-XML-LibXML                             ppc                      2.0012-1                     @/perl-XML-LibXML-2.0012-1.aix5.1.ppc                              3.5 M
     perl-XML-NamespaceSupport                   noarch                   1.11-1                       @/perl-XML-NamespaceSupport-1.11-1.aix5.1.noarch                    38 k
     perl-XML-Parser                             ppc                      2.41-1                       @/perl-XML-Parser-2.41-1.aix5.1.ppc                                1.4 M
     perl-XML-SAX                                noarch                   0.99-1                       @/perl-XML-SAX-0.99-1.aix5.1.noarch                                157 k
     perl-XML-SAX-Base                           noarch                   1.08-1                       @/perl-XML-SAX-Base-1.08-1.aix5.1.noarch                           199 k
     perl-XML-Simple                             noarch                   2.18-1                       @/perl-XML-Simple-2.18-1.aix5.1.noarch                             201 k
     rrdtool-perl                                ppc                      1.7.0-3                      @AIX_Toolbox ;                                                      112 k
    I uninstalled all the packages and tried a fresh install of the new version of perl. This was successful. When I tried to reinstall the dependent packages I now get a failure:

    Error: Package: perl-TimeDate-1.20-1.noarch (/perl-TimeDate-1.20-1.aix5.1.noarch)
               Requires: perl(:MODULE_COMPAT_5.8.8)
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest

    I did some searching and cannot find any packages newer than the ones found on the LPAR2RRD site for the rrdtool version found on AIX 7.2.

    Is there another repository that has packages that are compatible with the newest version of perl5 from the AIX Toolbox (1:5.28.0-1) or do I have to simply go back to the earlier version of perl (5.8.8-2) and reinstall the is compatible packages?
  • Use --force option ir rpm install

  • I tried that and got the following output:

    # rpm -ihv --force perl-TimeDate-1.20-1.aix5.1.noarch.rpm
    error: Failed dependencies:
            perl(:MODULE_COMPAT_5.8.8) is needed by perl-TimeDate-1.20-1.noarch
  • Here is the output of the yum list of installed perl5 packages:

    #yum list |grep perl
    perl.ppc                                   1:5.28.0-1       @AIX_Toolbox
  • get source package and install it under new perl.

    Depends what do you want to use.
    1. if you want to use new perl for lpar2rrd then installing from source code is definitelly solution
    rest of packages use only from ibm site

  • then install all dependecy packages via yum and perl-TimeDate from source package, this should work
  • I was not able to get the dependency packages or all the source packages to install. Since this is our development server, I decided to try a clean install from LPAR2RRD 5.07 build. I unmounted the old directories and built a new directory. I downloaded the 5.07 tar ball and made sure all the base packages (or their newer versions) were successfully installed. When I ran the install script, I got the following message:

    LPAR2RRD installation under user : "lpar2rrd"
     make sure it is realy the user which should own it

    Where LPAR2RRD will be installed [/var/lpar2rrd/lpar2rrd]:

    Creating /var/lpar2rrd/lpar2rrd

    Extracting distribution
    Copy distribution to the target location
    Copy GUI files : /var/lpar2rrd/lpar2rrd/www
    Setting up directory permissions
    Configuring /var/lpar2rrd/lpar2rrd/etc/lpar2rrd.cfg

    ERROR: Perl module has not been found: RRDp

    Install all missing Perl modules and do this test again, check
    Usage: cd ./scripts/.; . etc/lpar2rrd.cfg; $PERL bin/

    Could not load program /usr/bin/rrdtool:
    Could not load module /opt/freeware/lib/libcairo.a(
            Dependent module /opt/freeware/lib/libXrender.a( could not be loaded.
            Member is not found in archive
    Could not load module rrdtool.
            Dependent module /opt/freeware/lib/libcairo.a( could not be loaded.
    Could not load program /usr/bin/rrdtool:
    Could not load module /opt/freeware/lib/libcairo.a(
            Dependent module /opt/freeware/lib/libXrender.a( could not be loaded.
            Member is not found in archive
    Could not load module rrdtool.
            Dependent module /opt/freeware/lib/libcairo.a( could not be loaded.
    Condider RRDtool upgrade to version 1.3.5+ (actual one is )
    This will allow graph zooming:

    Installation has finished
    Follow post-install instructions at:

    I double checked and the rrdtool and perl-rrdtool packages:

      rrdtool                       1.7.0-3    C     R    Round Robin Database Tool to
      rrdtool-perl               1.7.0-3    C     R    Perl RRDtool bindings

    are installed correctly.  Is there something additional I need to install to resolve the apparent missing perl module?
  • is this exist /opt/freeware/bin/perl ?
    if so place it use PERL=/opt/freeware/bin/perl in etc/lpar2rrd.cfg

    . etc/lpar2rrd.cfg; $PERL bin/

  • Ok, I managed to build the new installation of LPAR2RRD with perl.ppc (5.8.--2.aix5.1.ppc) and have it set to try the upgrade to the AIX Toolbox version of perl.ppc (1:5.28.0-1). Before I do so, I wanted to check to see if anyone else has done this upgrade and how they adjusted for failed dependencies. I had tried downloading the newest source code for each of these, but was running into issues with compiling them and getting them to work with the other modules.
  • This is something we have in our labs, it is working.
      perl.rte            C     F    Perl Version 5 Runtime

  • edited November 2018
    After some digging I have come across the source of the issue. The perl version installed as part of the LPAR2RRD build ( has compatibility modules as part of the base package:

    $ rpm -q --provides perl | grep MODULE_COMPAT

    This allows for the installation of the dependent packages

    Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-XML-NamespaceSupport-1.11-1.noarch
    Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-XML-SAX-0.99-1.noarch
    Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-URI-1.58-1.noarch
    Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-XML-SAX-Base-1.08-1.noarch
    Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-XML-Parser-2.41-1.ppc
    Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-XML-LibXML-2.0012-1.ppc
    Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-XML-Simple-2.18-1.noarch
    Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-TimeDate-1.20-1.noarch

    The AIX Toolbox version does not have this module defined. As a result none of the additional perl packages from the LPAR2RRD install can be loaded and the installation of the new version of perl fails.

    Is there a means by which this issue can be overcome? The Perlz site where the original packages are sourced from does not have any newer versions of these packages. I have tried loading newer versions from source code (granted that I am not an expert at using perl), but it does not seem to work. 

    Will the versioning issue be addressed with the release of the combined lpar2rrd/store2rrd package due for release in 1Q2019?

  • AIX dependency hell ...

    We suggest to keep older version from Perlz site, it is working fine, installation is described in the docu.

    Xormon (lpar2rd/stor2rrd merge) will not definitelly support AIX, this save us and users a lot of time of such conversation :(

    BTW on Linux all dependency packages is question of one "yum" command ...
  • Pavel, we do have the same version of the perl.rte you noted running on this server. Do you think pointing the lpar2rrd config toward that fileset will get us out of using the RPMs? I understand completely the pitfalls of dependency hell and this is not the first time I have run into issues with it.

    Am I understanding your last post correctly in that Xormon will not be able to run on an AIX host or will not be supported on a AIX host? Presently, our team has no access to any Linux hosts and none of the company's current Linux hosts are connected in any way to our HMCs. In short, will we have to host Xormon on Linux in order for us to use this product?

  • yes, Xormon will run on Linux only include Linux on Power. No AIX.
    However lpar2rrd will stay as a separate product, we do not plan to stop its development and support.

    What Perl do you actually have?
    What is actual problem?
Sign In or Register to comment.