no SVP

Hi,

is there a possibility to get Hitachi VSP G700 to stor2rrd if I do not have SVP nor CCI configured.

for VSP G series the new management tool is Hitachi Ops Center.
SVP are deprecated.

cheers/sven


Comments

  • Hi,

    no, we do not support Ops center. It is in our voting list at https://stor2rrd.com/voting.php
    Actually we have no access to it, so cannot do anyhthing right now ...

    However you can use REST API, it definitelly works https://stor2rrd.com/Hitachi-VSPG-REST_API.php


  • willl try to get this to work. thank you very much.
  • Hi,

    still there is a need for SVP with hitachi G700 ?


    cheers/sven


  • use node IP instead, try it


  • replaced SVP ip with one of the node(controller) IP.


    cheers/sven

  • Hello Sven,

    set SVP IP correctly (not node IP)

    su -l stor2rrd (lpar2rrd on Virtual Appliance)

    cd /home/stor2rrd/stor2rrd # or where is your STOR2RRD working dir

    ./bin/config_check.sh <STORAGE_ALIAS>


    Thank you
  • so the SVP ip is needed and there is no way arount SVP?

    just want to make that clear..

    cheers/sven
  • Hello Sven,

    I think it should work. Try to install export tool 2 ( for VSP G700). Export tool version 1 uses SVP IP. Export tool version 2 uses node IP.

    Thank you
  • Dariusz
    edited April 20
    Hello Team, 
    I have the same issue: we bought few E790 without SVP :smile:
    I'm trying to get data via Export Tool 2, but i have an errors (SVP and CTRL 1 same IP and 2nd CTRL (other IP)):


    [stor2rrd@wroxxxv stor2rrd]$ ./bin/config_check.sh S2_E790_******

    =========================
    STORAGE: S2_E790_******: VSPG
    =========================
      WARNING : TCP connection to "10.99.******1" on port "1099" has failed! It might need to be open on the firewall.
      WARNING : TCP connection to "10.99.******1" on port "51099" has failed! It might need to be open on the firewall.
      WARNING : TCP connection to "10.99.******1" on port "51100" has failed! It might need to be open on the firewall.
      WARNING : TCP connection to "10.99.******1" on port "51101" has failed! It might need to be open on the firewall.
      REST API TEST

      TCP connection to "10.99.******1" on port "443" is ok
    /usr/bin/perl /stor2rrd/stor2rrd/bin/vspg_apitest.pl stor2rrd XXXXX CTRL1 https S2_E790_****** apitest CTRL1 CTRL2


      Machine Name: S2_E790_******

      Machine Type-Model: VSP E790

      Machine Serial: 611329

      IP address controller A: 10.99.******1

      IP address controller B: 10.99.******2

      Software Version: 93-06-01/00

    Export tool version : 2

      TCP connection to "10.99******1" on port "443" is ok
      TCP connection to "10.99******2" on port "443" is ok

    Sample rate : 5 min

    Start export performance data
    +----+----+----+----+----+----+----+----+----+----+
    >                                                   0.0%
    An API server error (HTTP error) occurred. (URL = https://10.99.******1:443/cgi-bin/dump.cgi2?dumpType=performance&sso=cbbf44926dc64c9485371747d63293ed&range=182-182, HTTP Status-Code = 503, details = Service Not Available) [MSG ID = 8014]

    Communication is being retried. (1/10) [MSG ID = 7006]                                                                                                         ==================================================> 100.0%
    Plot:1(2022/04/20 04:48 - 2022/04/20 04:48)
    export data command success
      connection ok


    No SAN configured :
    No LAN configured :

    In theory connection is ok. I know some ports are locked (i will open it).
    But i'm getting an error "Service Not Available"


    Do you have any idea how we can connect to the array?

    Regards,
    Dariusz
  • Error is ok, everything is working with export tool 2 :smile:

Sign In or Register to comment.