Adding Hitachi VSP 5K using rest API

edited June 2020 in Hitachi
So what should have been a pretty straightforward storage add is giving me head ache :(

When I add in the array, I get below, everything passes except the API data test:

So I thought ok, it is complaining that the directory /90-04-02 no being found. I tried both soft linking and then also copying the directory to the root directory. Then I get this error below.

What am I missing?


  • @Pavel @Karel @Lukas Any pointers where I am going wrong? I have tried a whole host of things but cannot seem to make any headway.
  • Hi,

    run it on the command line (you should ot be run via web (apache user does not have enough of rights)

    cd /home/stor2rrd/stor2rrd
    ./bin/ <storage name>
  • When I run from the CLI I get this error. Not sure what is the IPB
  • Also I am not sure if this model VSP 5500H fits into the VSP-G of VSP 5000 definition in stor2rrd. For completeness I have tried both but I get the same issue both times.
  • Hi,

    send us logs

    Note a short problem description in the text field of the upload form.

    cd /home/stor2rrd/stor2rrd # or where is your STOR2RRD working dir

    tar cvhf logs.tar logs tmp/*txt

    gzip -9 logs.tar

    Send us logs.tar.gz via

  • Hello,

    I recommend upgrading to the latest version (2.81). These errors should be fixed in the latest version.

    Thank you
  • Thank you. Will upgrade and test and let you know.
  • Upgraded and added with REST API, works like a charm. Thank you
Sign In or Register to comment.